[Issues] [mod_auth_xradius 0000098]: Can't get mod_auth_xradius to complile under Solaris 10 SPARC

Mantis Bug Tracker issues at outoforder.cc
Fri Mar 16 13:14:00 EDT 2012

A NOTE has been added to this issue. 
Reported By:                diggins
Assigned To:                
Project:                    mod_auth_xradius
Issue ID:                   98
Category:                   Compile or Build
Reproducibility:            always
Severity:                   major
Priority:                   normal
Status:                     new
Apache Version:             2.0.40 
Date Submitted:             2009-05-09 15:37 EDT
Last Modified:              2012-03-16 13:14 EDT
Summary:                    Can't get mod_auth_xradius to complile under Solaris
Configure runs ok, but make fails with the errors below.

Additional Information: 
diggins at nwebdns<src/mod_auth_xradius-0.4.6># ./configure
configure: creating config.nice
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... sparc-sun-solaris2.10
checking host system type... sparc-sun-solaris2.10
checking target system type... sparc-sun-solaris2.10
checking for a BSD-compatible install... config/install-sh -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... nawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /usr/local/bin/sed
checking for egrep... egrep
checking for ld used by gcc... /usr/ccs/bin/ld
checking if the linker (/usr/ccs/bin/ld) is GNU ld... no
checking for a BSD-compatible install... config/install-sh -c
checking for ranlib... ranlib
checking for apxs... /usr/local/apache2/bin/apxs
checking for Apache 2.0 version >= 2.0.40... yes
checking dynamic linker characteristics... solaris2.10 ld.so
checking for apr_memcache library in /usr/local/apache2/lib... no
checking for apr_memcache library in /usr/local/lib... no
checking for apr_memcache library in /usr/lib... no
checking for apr_memcache library in /usr/local/apache2/lib... no
configure: *** memcache library not found.
configure: creating ./config.status
config.status: creating Makefile
config.status: creating include/mod_auth_xradius.h
config.status: creating include/mod_auth_xradius_config.h
config.status: executing depfiles commands
Configuration summary for mod_auth_xradius:

   * mod_auth_xradius version:  0.4.6
   * Apache Modules directory:  /usr/local/apache2/modules

diggins at nwebdns<src/mod_auth_xradius-0.4.6># make
if /usr/local/apache2/build/libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I.
-I./include    -Wall -I./libradius   -L/usr/local/lib -R/usr/local/lib
-L/usr/local/ssl/lib -R/usr/local/ssl/lib -L/usr/openwin/lib -R/usr/openwin/lib 
-I/usr/local/apache2/include  -I/usr/local/apache2/include  
-I/usr/local/apache2/include -I/usr/local/include -g -O2 -MT
mod_auth_xradius_la-mod_auth_xradius.lo -MD -MP -MF
".deps/mod_auth_xradius_la-mod_auth_xradius.Tpo" -c -o
mod_auth_xradius_la-mod_auth_xradius.lo `test -f 'src/mod_auth_xradius.c' ||
echo './'`src/mod_auth_xradius.c; \
then mv -f ".deps/mod_auth_xradius_la-mod_auth_xradius.Tpo"
".deps/mod_auth_xradius_la-mod_auth_xradius.Plo"; else rm -f
".deps/mod_auth_xradius_la-mod_auth_xradius.Tpo"; exit 1; fi
mkdir .libs
 gcc -DHAVE_CONFIG_H -I. -I. -I./include -Wall -I./libradius -L/usr/local/lib
-R/usr/local/lib -L/usr/local/ssl/lib -R/usr/local/ssl/lib -L/usr/openwin/lib
-I/usr/local/apache2/include -I/usr/local/apache2/include
-I/usr/local/apache2/include -I/usr/local/include -g -O2 -MT
mod_auth_xradius_la-mod_auth_xradius.lo -MD -MP -MF
.deps/mod_auth_xradius_la-mod_auth_xradius.Tpo -c src/mod_auth_xradius.c  -fPIC
-DPIC -o .libs/mod_auth_xradius_la-mod_auth_xradius.o
In file included from src/mod_auth_xradius.c:29:
libradius/radlib.h:196: error: parse error before "xrad_cvt_int"
libradius/radlib.h:196: warning: type defaults to `int' in declaration of
libradius/radlib.h:196: warning: data definition has no type or storage class
libradius/radlib.h:206: error: parse error before "u_int32_t"
*** Error code 1
make: Fatal error: Command failed for target
diggins at nwebdns<src/mod_auth_xradius-0.4.6># 


 (0000144) diggins (reporter) - 2009-05-09 15:38
I should add that I also tried compiling it on Solaris 8 SPARC with similar

 (0000296) mitcheli (reporter) - 2012-03-14 10:29
I beleive I solved this one. I had to make a few changes to the code base, for
all the declarations of "u_int32_t", I changed them to "int". On this note, I'm
also working on compiling to Apache 2.4.1 and as such, their function names
changed so the reference to "unixd_config" had to be changed to
"ap_unixd_config". With these modifications, I was able to get the code to
compile. But the million dollar question is, will it work... dum dum da.... :) 

 (0000297) mitcheli (reporter) - 2012-03-16 13:14
Beyond this there are a few other issues getting to compile. There are functions
that need to be defined that are usually associated with edian.h in Linux and
the md5c.c file needed some tweaking because the le32toh and htol332 functions
don't exist in Solaris (type casting to uint32_t worked ok.)

So I was able to get it to compile and to load into Apache, but now to figure
out the configs. ;) 

Issue History 
Date Modified    Username       Field                    Change               
2009-05-09 15:37 diggins        New Issue                                    
2009-05-09 15:37 diggins        Apache Version            => 2.0.40          
2009-05-09 15:38 diggins        Note Added: 0000144                          
2012-03-14 10:29 mitcheli       Note Added: 0000296                          
2012-03-16 13:14 mitcheli       Note Added: 0000297                          

More information about the Issues mailing list