[Mod_ftpd] clarification needed on manual.html instructions

Kamin Whitehouse kaminw at yahoo.com
Mon Apr 18 20:53:30 EST 2005

I've got mod_ftpd compiled and installed, but the
server never gives me a username/password prompt. 
After "gmake install", all I did is copy the sample
configuration from the manual.html file directly into
my httpd.conf file (after fixing a few typos).  Then,
I restarted apache and tried:
"$ ftp myserver.com"

but there is no response from the server.  A few other
people on the gentoo forums seem to be having the same
problem.  I've opened my firewall and have no problems
with other ftp servers like vsftpd.  

does anybody know what the problem is, or have more
specific installation instructions?  In particular,
there were a few things in the instructions that I
wasn't sure about:

1.  am I supposed to change the <VirtualHost *:21>
directive to have a hostname directive?

2.  what are the modules/mod_ftpd_dbm.so,
modules/mod_ftpd_dbi.so,  and    
modules/mod_ftpd_fail.so modules for?

3.  what are the PASV ports?

4.  what are all these directives: 
anonymous_authoritative, AuthAuthoritative,
Anonymous_NoUserID, Anonymous anonymous, AuthName ftp?
   In particular, does one of these turn
authentication on/off?  What would the correct
settings be for anonymous and password/anonymous
only/password only?

5.  is there a way to define a filesystem path for a
<Location> directive?  For example, subversion's
mod_dav_svn allows you to declare:

<Location /mydir>
DAV svn
SVNPath /local/fs/dir/name

Any help getting this to work would be great...
mod_ftpd is *exactly* what I need because it uses
apache authentication.  My configuration uses apache
2.0.52 with RH9, but I've also tried with an updated
gentoo machine.

I should be suscribed to this list, but haven't gotten
a confirmation email yet, so please cc me directly in
your response just in case.

Do you Yahoo!? 
Make Yahoo! your home page 

More information about the Mod_ftpd mailing list