[Modules] PATCH: mod_gnutls README

Jack Bates ms419 at freezone.co.uk
Tue Sep 30 13:53:30 EDT 2008

On Mon, 2008-09-29 at 10:44 +0300, Nikos Mavrogiannopoulos wrote:
> Jack Bates wrote:
> > - but when I start Apache, it complains:
> > 
> > ket% /usr/sbin/apache2 -f httpd.conf
> > Syntax error on line 16 of httpd.conf-gpg:
> > GnuTLS: Failed to Import PGP Private Key '/home/jablko/trash/key.asc':
> > (-59) GnuTLS internal error.
> > ket% 
> Hello,
>  gnutls and mod_gnutls cannot read encrypted openpgp keys. That is your
> gpg key must not be protected with a passphrase.

Doh - thank you Nikos : )

I created a key without a passphrase and got a bit further. I also found
some documentation in the GnuTLS manual on creating OpenPGP server

I created this patch for the mod_gnutls README, to add instructions for
creating OpenPGP server credentials:

Would you consider applying it?

Unfortunately, I am still stuck. As per the instructions in the GnuTLS
manual, I created a gpg key using my server name. I tried "localhost"
and added "ServerName localhost" to my httpd.conf. However, when I try
to start Apache, the error log complains:

[Tue Sep 30 10:33:37 2008] [emerg] [GnuTLS] - Host 'localhost:0' is
missing a Certificate File!

I also tried creating a gpg key using "localhost:0" - with the same

Here is my httpd.conf:

- and a screenlog of how I generated the OpenPGP server credentials:
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
Url : http://lists.outoforder.cc/pipermail/modules/attachments/20080930/efa09d7a/attachment.bin 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 1920 bytes
Desc: not available
Url : http://lists.outoforder.cc/pipermail/modules/attachments/20080930/efa09d7a/attachment-0001.bin 

More information about the Modules mailing list