[Modules] mod_gnutls making Apache use 100% CPU

Sander Marechal s.marechal at jejik.com
Fri Apr 24 04:36:52 EDT 2009


I have a problem with mod_gnutls. It makes Apache use 100% CPU. When I
visit one on my domains on the server with a browser it just keeps on
"connecting..." forever (this is Firefox 3 on Linux, it has SNI
support). There is nothing in the logfiles and loglevel is set to debug.

I am sure it is caused by mod_gnutls. All domains that do not use
mod_gnutls work fine. Requests made to domains that do use mod_gnutls
never get anywhere. I ran my PHP debugger (xdebug) and it doesn't show
up, meaning that the request never even makes it to PHP. It gets stuck
before that.

Everything was working fine up to 5 AM this morning (as indicated by the
logfiles). Nothing changed on the server. I tried restarting Apache and
even rebooting the server. Didn't help.

How can I debug this? Here's a typical configuration for one of my domains:

<VirtualHost *:443>
        DocumentRoot /path/to/docroot
        ServerName example.org:443

	# SSL using GnuTLS
	GnuTLSEnable On
	GnuTLSCertificateFile /etc/apache2/ssl/example.org.cert
	GnuTLSKeyFile /root/certs/example.org.key
	GnuTLSClientVerify require
	GnuTLSClientCAFile /etc/ssl/certs/cacert.org.pem

        ErrorLog /var/log/apache2/error.log
        LogLevel debug

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

Sander Marechal

More information about the Modules mailing list