[Modules] Session Cache is not configured - hint SSLSessionCache

ml at alexg.org ml at alexg.org
Thu Jan 1 15:12:35 EST 2009


I am currently trying to install mod_gnutls on FreeBSD 6.3 within a Jail.
- Apache 2.2.10 (also tried 2.2.8)
- mod_gnutls 0.5.3 (also 0.4.3, svn)

Everytime I try to start apache I'll get an error-log entry as follows:

"[Thu Jan 01 20:05:12 2009] [warn] Init: Session Cache is not configured
[hint: SSLSessionCache]"

And httpd just quits without any further notice (no crash, just nothing).

Maybe someone can help with this. As said above, I tried several versions
of mod_gnutls.

If I comment out my SSL-Vhost und just leave the gnutls config in, apache
starts up correctly.

A cache file is created as well:
"GnuTLSCache dbm /var/cache/gnutls"
ls -al /var/cache/
total 16
drwxrwxrwx   2 www   www      512 Jan  1 19:47 .
drwxr-xr-x  23 root  wheel    512 Jan  1 13:24 ..
-rw-r--r--   1 www   www    12288 Jan  1 20:05 gnutls

Here are my config details:

-- httpd.conf --
Listen <ip>:80
Listen <ip>:443

LoadModule gnutls_module libexec/apache22/libmod_gnutls.so

NameVirtualHost *:443
NameVirtualHost *:80

AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl    .crl

GnuTLSCache dbm /var/cache/gnutls
GnuTLSCacheTimeout 600

<VirtualHost *:443>
        ServerName test.foo.bar
        SuexecUserGroup testfoobar testfoobar
        DocumentRoot /usr/local/www/domains/test.foo.bar/html
        CustomLog /usr/local/www/domains/test.foo.bar/logs/access_log
        ErrorLog /usr/local/www/domains/test.foo.bar/logs/error_log
        GnuTLSEnable on
        GnuTLSKeyFile /usr/local/etc/apache22/ssl_certs/test.foo.bar_key

-- end --


More information about the Modules mailing list