[Modules] mod_gnutls serving only 1 certificate?

Jonathan Richard richajon at gmail.com
Thu Oct 7 10:34:24 EDT 2010

Hi Thanks for the reply.

I am guessing that firefox 3 is SNI compliant. Anyhow, I found a solution to
my problem but it is not gnutls related. I used mod_ssl instead. I did not
support virtualhost SSL up until version 0.9.8j and apache 2.2.12. I tried
gnutls since I was sure that mod_ssl did not support it. Not it does so...
problem solved. Reference:



On Thu, Oct 7, 2010 at 3:00 AM, Nikos Mavrogiannopoulos <nmav at gnutls.org>wrote:

> On 10/05/2010 06:00 PM, Jonathan Richard wrote:
> > Hi
> >
> > I am trying to configure apache2 with gnutls so I can have 2 SSL secured
> > virtual hosts (domains) using only 1 IP address.
> [...]
> > Everything seems to works fine, the domain maps to the proper web sites
> but
> > for some reasons, the only one certificate is used. i.e. if I hit
> > test1.dyndns.org in firefox and display certificate information, the
> > provided certificate is the one configured in test2.dnsdns.info. In
> short,
> > it seems like apache2 serves only 1 certificate not mater which domain
> name
> > is served.
> In order for multiple domain names to work you need to have a browser
> that supports SNI. If you verified that this is the case, then check
> the configuration examples in the site.
> regards,
> Nikos
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.outoforder.cc/pipermail/modules/attachments/20101007/1bc01391/attachment.html 

More information about the Modules mailing list