[Modules] [mod_gnutls 0.4.3] Site not accessible

Thomas Off toff at barff.de
Wed May 14 05:07:10 EDT 2008

Hello Ernie,

thanks for the link and all the help. I finally managed to get it to
run. The error was a misconfiguration of my apache not listening on the
SSL port 443 (the "Listen" directive was there but masked by an
"IfModule" directive requiring mod_ssl). Once again thanks for your


> What error are you getting? How are you generating your certificate?
> My certificates were generated using one of the dozens of 
> sites found  
> through google (search: generate self-signed ssl certificate). This  
> was way over a year ago, so I don't recall the exact site I 
> used, but  
> they're basically all the same. The only gotcha I have run into is  
> seen on the client side when I don't pay attention to the serial  
> number for previously generated certificates. See  
> http://www.tc.umn.edu/~brams006/selfsign.html for a good 
> discussion &  
> instructions on this topic.
> Ernie
> > Hello Ernie,
> >
> >> Agreed, the instructions are for old versions. For what it's
> >> worth, I
> >> recently posted instructions (mostly for my own reference) on how I
> >> started from where you are and upgraded to a more recent
> >> version. See
> >> http://drhymel.com/blog/?p=24. Hope it helps, let me know.
> >>
> >> Ernie
> >
> > Thanks for the link. I've recompiled everything and tried 
> again but it's
> > still not working.
> > Could my certificates be the reason for the error? How are 
> ypu creating
> > the certificates for your server?
> >
> > Regards,
> > Thomas

More information about the Modules mailing list